URL Problems

A place to discuss and receive support for the Web Auction application.

Postby Dave » Sun Jun 17, 2007 2:09 pm

Hi

I have setup the auction site to sell some old equipment to raise money for charity and Web Auction looks exactly like what we need I have a couple of problmes that i cant work out and if some one could help would be great?

It is running on Win 2003 Svr with IIS6, PHP 5.0.4, mysql v5

1, The image links to the auction items dont work under IE6 they are missing the url of the site and you cant login, This may be becuase some of the URL's are badly formatted ie have extra backslashes and in someplaces fordward slashes (not sure what i have wrong here)

IE6
http://tables/products/product_image/HP_s7540.jpg
http://charityauction//tables/products/ ... _s7540.jpg
http://charityauction\/index.php?-action=browse&-table=products_categories=6

2, You cannot log out, it times out with the error cant find page.

Login

Thanks for you help

Dave
Dave
 
Posts: 5
Joined: Wed Dec 31, 1969 5:00 pm

Postby Dave » Sun Jun 17, 2007 2:19 pm

My post is missing most of the info between "IE6" and "Thanks for you help" I will try again.


THe second problems is that I can login with IE7 because it handles the malformed URL's but then you cannot log out it times out with page cannot be found the URL is (i added some spaces)

(< a href="http : // charityauction\/index.php?-table=products&-action=logout&-cursor=0&-skip=0&-limit=30&-mode=list&-sort=product_categories+asc" title="Logout">Logout< /a >)
Dave
 
Posts: 5
Joined: Wed Dec 31, 1969 5:00 pm

Postby shannah » Mon Jun 18, 2007 10:01 am

Hi Dave,

Thanks for posting.Ê IIS is somewhat uncharted territory for Dataface.Ê I have installed it a couple of times on IIS and I've heard of other people using it on IIS, but most people are running it on Apache.Ê So there could be some bugs that show up on IIS that don't show up on Apache.

That said, we can start trying to solve this problem by looking in the config.inc.php file and seeing what the site path and urls are set to.Ê If there are some weird backslashes, change them.

Another issue to be concerned with on IIS is that it doesn't use .htaccess files.Ê You will want to take measures to make sure that your web server doesn't publish the conf.ini file, because it contains username/password info to the database.Ê In apache this is achieved using an .htaccess file.Ê I'm not sure how it's done with IIS - but there is surely a way.

Let me know how it goes.

-Steve

--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Postby Dave » Tue Jun 19, 2007 11:12 pm

Thanks for the responce Steve, I have tried all sorts of options to fix but it must be with IIS.

Do you have any other ideas? I cant install apache on this server, security isnt a big problem it will be an internal site only.

The problem is the the links are all created with a \ after the host name.

i.e.
http : // charityauction \ / index.php?-table=p...

Thanks again

Dave
Dave
 
Posts: 5
Joined: Wed Dec 31, 1969 5:00 pm

Postby shannah » Wed Jun 20, 2007 1:49 am

hi Dave,

It would help me to know what the contents of the config.inc.php file are.

--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Postby Dave » Wed Jun 20, 2007 3:36 am

Hi Steve

I appreciate your help, this is the config.inc.php file I have tried a few options using relative paths ect appears to make no diffrence.
i put the spaces in the url so it would post.

Thanks

Dave



* @created April 11, 2007
*
* Change these values to correspond with the location of your dataface install
* location.
*/
define('DATAFACE_INSTALLATION_PATH', 'D:\data\WebSites\web_auction\dataface');

// The path to your dataface installation. This can be relative to the
// index.php file, or absolute.

define('DATAFACE_INSTALLATION_URL', 'http: // charityauction/dataface');
// The URL to your Dataface installation location as you would type it
// into a web browser. This can also be relative to your index.php
// file, or it can be absolute (e.g. http://www.yourdomain.com/dataface)
?>
Dave
 
Posts: 5
Joined: Wed Dec 31, 1969 5:00 pm

Postby shannah » Wed Jun 20, 2007 4:37 pm

Is that charityauction domain correct?Ê What is the full domain where it is hosted.Ê You probably mean to have something like:

http://yourdomain.com/charityauction/dataface

-Steve

--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Postby KenKirchner » Wed Jun 20, 2007 5:12 pm

Something you can try is replacing line 33 in dataface\init.php with -

define('DATAFACE_SITE_URL', str_replace( '\\', '/', dirname($_SERVER['PHP_SELF'])));

This worked here, where I found the same url problem. I thought there was one other thing I needed to change, but I can't verify that right now.
KenKirchner
 
Posts: 4
Joined: Wed Dec 31, 1969 5:00 pm

Postby Dave » Thu Jun 21, 2007 3:53 am

Something you can try is replacing line 33 in dataface\init.php with -

define('DATAFACE_SITE_URL', str_replace( '\\', '/', dirname($_SERVER['PHP_SELF'])));


Hey it worked a treat; it is now 100% including the logout function.

Thanks Ken and Steve for all your help, Steve it?s a great piece of software will be really handy.

Dave
Dave
 
Posts: 5
Joined: Wed Dec 31, 1969 5:00 pm

backslash problem

Postby sophistry » Wed Apr 01, 2009 6:38 am

After a year and a half, I'm resurrecting this post, just to give a big thank-you. After wrestling with this problem when porting a linux install of Xataface to a WinXP machine running xampp/apache, it worked.. It took me a day and a half of searching and poking to find this fix, and it was exactly what I was looking for.

Thanks Again!
Rory
sophistry
 
Posts: 27
Joined: Mon May 19, 2008 11:20 am


Return to Web Auction Discussion

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron
Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved