Installation help

A place to discuss and receive support for the Web Auction application.

Postby JediMasterNerd » Fri Sep 21, 2007 1:36 pm

Hello -

I've gone through the other threads and haven't seen anyone experience this so I'm assuming there is something wrong with the configuration on my webhost or something like that. I've tried this on 2 different hosts with the same results so it's also possible that I just missed something :)

MySql Version: 4.0.25
PHP Version: 4.4.7
Dataface 0.7.1 is detected and the info page reports install completed...

When I try to install WebAuction I got errors during table creation. I had to remove DEFAULT CHARSET=latin8 and the DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP in order to get the tables created.

After getting the tables created I went to test the site and I get an on the select for p.product_id, current_high_bid:
Fatal error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'select p.*,current_high_bid from products p left join (select pSELECT COUNT(*) FROM (select p.*,current_high_bid from products p left join (select product_id,max(bid_amount) as current_high_bid from bids group by product_id) as b on p.product_id=b.product_id) as `products`On line 99 of file /usr/local/www/virtual1/66/175/46/156/html/dataface-0.7.1/Dataface/QueryTool.php in function printstacktrace()
On line 462 of file /usr/local/www/virtual1/66/175/46/156/html/dataface-0.7.1/Dataface/QueryTool.php in function dataface_querytool(products,Resource id #12,array(e473465e3e88c6658e657f0eff681bf6,products,list,0,0,30,list,product_categories asc))
On line 955 of file /usr/local/www/virtual1/66/175/46/156/html/dataface-0.7.1/Dataface/Application.php in function loadresult(products,Resource id #12,array(e473465e3e88c6658e657f0eff681bf6,products,list,0,0,30,list,product_catego in /usr/local/www/virtual1/66/175/46/156/html/dataface-0.7.1/Dataface/QueryTool.php on line 99


If I change product/fields.ini around to not have an embedded select with the left join:
__sql__="SELECT p.product_id, max(b.bid_amount) as current_high_bid FROM products p LEFT JOIN bids b ON p.product_id = b.product_id GROUP BY p.product_id"

it gets passed that error but produces a new error:
Fatal error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT p.product_id, max(b.bid_amount) as current_high_bid FROSELECT COUNT(*) FROM (SELECT p.product_id, max(b.bid_amount) as current_high_bid FROM products p LEFT JOIN bids b ON p.product_id = b.product_id GROUP BY p.product_id) as `products`On line 99 of file /homepages/33/d87621851/htdocs/wsc87621859/dataface-0.7.1/dataface-0.7.1/Dataface/QueryTool.php in function printstacktrace()
On line 462 of file /homepages/33/d87621851/htdocs/wsc87621859/dataface-0.7.1/dataface-0.7.1/Dataface/QueryTool.php in function dataface_querytool(products,Resource id #12,array(228b182127e83675cd3ae8441e1aa55e,products,list,0,0,30,list,product_categories asc))
On line 955 of file /homepages/33/d87621851/htdocs/wsc87621859/dataface-0.7.1/dataface-0.7.1/Dataface/Application.php in function loadresult(products,Resource id #12,array(228b182127e83675cd3ae8441e1aa55e,products,list,0,0,30,li in /homepages/33/d87621851/htdocs/wsc87621859/dataface-0.7.1/dataface-0.7.1/Dataface/QueryTool.php on line 99


.....


Anyway, before I work through each one of these and possibly make things worse I thought I would see if I'm missing something. Obviously this works for others so it's got to be my environment or something like that!

Thanks,
Steve.
JediMasterNerd
 
Posts: 2
Joined: Wed Dec 31, 1969 5:00 pm

Postby JediMasterNerd » Fri Sep 21, 2007 1:47 pm



>MySql Version: 4.0.25

PHP Version: 4.4.7

>Dataface 0.7.1 is detected and the info page reports install completed...



Well, I think I answered my own question here... I just double checked the requirements and MySql 4.1+ is required and I only have MySql 4.0.25 on one server and 4.0.27 on another...

So if that's the case, never mind... Maybe I'll plug away and see if I can come up with something...

Thanks,
Steve.
JediMasterNerd
 
Posts: 2
Joined: Wed Dec 31, 1969 5:00 pm

Postby shannah » Fri Sep 21, 2007 2:06 pm

Hi Steve,

Thanks for posting this. The problem is that you need MySQL 4.1 or higher for Web Auction. It uses some nested queries and other features that aren't in 4.0 and below.

Best regards

Steve
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Postby andrewr » Wed Sep 26, 2007 2:58 pm

Hi Steve,

Thank you for a great product. I spent a few hours trying to install this on 1 host until I found this post. My host had MySQL 4.0

I do not know PHP that well, but an idea that I had is to have a query built into the installer.php file (perhaps even before it looks for dataface) to check and report the version of MySQL & PHP.

Then tell the User - You do / do no have the required versions to run this software.

If they do, click here to continue - then take em to the dataface check / other info page.

Just a suggestion - and once again thank you very much for your time and effort in creating this product.

I am trying to setup an auction for a charity event, and they did not need to spend huge amounts of money buying an ebay. So thank you.

Andrew
andrewr
 
Posts: 12
Joined: Wed Dec 31, 1969 5:00 pm

Postby shannah » Wed Sep 26, 2007 11:41 pm

Thanks for the suggestion. If I find time I'll see if I can do this. For now the requirements are listed in the readme file that comes with the distribution.
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Same problem for installation

Postby kennyken » Mon Jan 26, 2009 10:57 pm

Hi
I have a same trouble now,

MySql Version:[b] 4.1.22[/b]
PHP Version: [b]5.2.8[/b]

When I try to install WebAuction I got errors during table creation. I had to remove DEFAULT CHARSET=latin8 and the DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP in order to get the tables created.

My error is;
SELECT COUNT(*) FROM (select p.*,current_high_bid from products p left join (select product_id,max(bid_amount) as current_high_bid from bids group by product_id) as b on p.product_id=b.product_id) as `products`
Fatal error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'select p.*,current_high_bid from products p left join (select pSELECT COUNT(*) FROM (select p.*,current_high_bid from products p left join (select product_id,max(bid_amount) as current_high_bid from bids group by product_id) as b on p.product_id=b.product_id) as `products`On line 127 of file /home/relationship/www/yellowbook/auction/webauction/dataface/Dataface/QueryTool.php in function printStackTrace()
On line 526 of file /home/relationship/www/yellowbook/auction/webauction/dataface/Dataface/QueryTool.php in function Dataface_QueryTool(products,Resource id #13,array(,,,b2269bef61e866323b79b334273c0241,en,611c9356323e392ef5ba8467a2a1ad9a,products,list,list,0,0)
On line 1066 of file /home/relationship/www/yellowbook/auction/webauction/dataface/Dataface/Application.php in function loadResult(products,Resource id #13,array(,,,b2269bef61e866323b79b334273c0241,en,611c9356 in /home/relationship/www/yellowbook/auction/webauction/dataface/Dataface/QueryTool.php on line 127

Please check my website, test page;
http://relationship.sakura.ne.jp/yellow ... /index.php
from Step 5: Log In
At this point, your web auction installation is available here.
I clicked "here" on your install.php

Thats all
Please give me more your advice

Thanks
TETSUJI
kennyken
 
Posts: 5
Joined: Mon Jan 26, 2009 10:43 pm

Postby shannah » Mon Jan 26, 2009 11:21 pm

How sure are you about your MySQL version being version 4.1? The errors that you have been receiving suggest an older version (4.0 or earlier).
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

installation problem

Postby kennyken » Tue Jan 27, 2009 1:33 am

Hi shannah,
Thank you for your comment.
I got my version from phpmyadmin(ver.2.11.9.2) at the Sakura rental server, Japanese company.
MySQL client version: 4.1.22
PHP version: 5.2.8
And I confirmed them at the service support centre by phone.

The Sakura rental server needs to set chmod .php -> 755
Does any other folder or files need to set chmod?

Thanks

[quote="shannah"]How sure are you about your MySQL version being version 4.1? The errors that you have been receiving suggest an older version (4.0 or earlier).[/quote]
kennyken
 
Posts: 5
Joined: Mon Jan 26, 2009 10:43 pm

Postby shannah » Tue Jan 27, 2009 11:58 am

Can you create a file named phpinfo.php with the following contents:
Code: Select all
<?php
phpinfo();


And point me to the output. The query that it is complaining about runs fine on all of my test installs. Something is fishy with either your MySQL server version or your MySQL client version.

On a side note, PHP files need only be chmod 644. 755 will work but it is more permissive than necessary.
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

I will try to upload and set up again.

Postby kennyken » Tue Jan 27, 2009 6:40 pm

Hi shannah,
Thank you for your comment. I checked the php version by phpinfo(). The PHP version is 5.2.8.

http://relationship.sakura.ne.jp/php_info.php
Please click this URL.

I will try to upload all files and set up chmod etc .... again.
If I will get a solution, I will post it here.

Thanks,
kennyken
 
Posts: 5
Joined: Mon Jan 26, 2009 10:43 pm

Postby shannah » Tue Jan 27, 2009 10:09 pm

There's your problem. Go down to the mysql section on your phpinfo page. It states your mysql client api version is 4.0.27.

Have your host upgrade it to 4.1 or higher in order for it to work. 4.0.x doesn't support subqueries which are required by webauction.

-Steve
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Postby kennyken » Tue Jan 27, 2009 10:56 pm

Hi Steve,

Thank you for your comment again.
I confirmed mysql client api version 4.0.27 and understood it.

Thank you very much.
kennyken
 
Posts: 5
Joined: Mon Jan 26, 2009 10:43 pm

Success for installation

Postby kennyken » Sun Feb 15, 2009 5:27 pm

Hi Steve,

I changed the rental server and installed Webauction the other day.
MySQL version is 5.0.67
It's OK, no problems.

Thanks
kennyken
 
Posts: 5
Joined: Mon Jan 26, 2009 10:43 pm


Return to Web Auction Discussion

Who is online

Users browsing this forum: Majestic-12 [Bot] and 3 guests

cron
Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved