Help: SMTP 530 error line 452 register.php

A place to discuss and receive support for the Web Auction application.

Help: SMTP 530 error line 452 register.php

Postby manskie » Wed Oct 21, 2009 6:43 am

I'm trying to restart an old Webauction installation (Which worked perfectly before) but cannot get users to registrate:

Warning: mail() [function.mail]: SMTP server response: 530 5.7.3 Client was not authenticated in D:\Inetpub\prhc.nl\LAPTOPS\dataface\actions\register.php on line 452

- I cleared all the products from the database and filled them again.
- I deleted all users exept admin and myself
- New user regs do not work because mail cannot be sent
- Mailserver IP-address may have changed but I cannot find a place where it is stored within webauction or MySql
- Simple test php mailscript is working:

$to = "mymail@myserver.nl";
$subject = "Hi!";
$body = "Hi,How are you?";
if (mail($to, $subject, $body)) {
echo("<p>Message successfully sent!</p>");
} else {
echo("<p>Message delivery failed...</p>");
}

Please help!
manskie
 
Posts: 6
Joined: Mon Sep 22, 2008 3:29 am

Postby shannah » Thu Oct 22, 2009 9:11 am

It just uses whatever settings you have in the php.ini file as it is just using the standard php mail() function. Sounds like have changed your mailserver to one that requires SMTP authentication and you don't have the credentials specified in your php.ini file.

Try a google search for "php.ini authenticated smtp mail server", or variations and you'll probably find some answers in quick order.

-Steve
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm


Return to Web Auction Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved